$re = '/[a-zA-Z-]+(\(
([0-9]+:[0-9]+)*\/
([0-9]+:[0-9]+)*\/*
([0-9]+:[0-9]+)*\/*
([0-9]+:[0-9]+)\))
[a-zA-Z-]*
/mx';
$str = 'CDP-DG(16:0/16:01)
CL(10:0/10:0/13:0/18:0)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);