const regex = /[a-zA-Z-]+(\(
([0-9]+:[0-9]+)*\/
([0-9]+:[0-9]+)*\/*
([0-9]+:[0-9]+)*\/*
([0-9]+:[0-9]+)\))
[a-zA-Z-]*
/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-zA-Z-]+(\\(
([0-9]+:[0-9]+)*\\\/
([0-9]+:[0-9]+)*\\\/*
([0-9]+:[0-9]+)*\\\/*
([0-9]+:[0-9]+)\\))
[a-zA-Z-]*
', 'gm')
const str = `CDP-DG(16:0/16:01)
CL(10:0/10:0/13:0/18:0)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}