#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)^(?:.*?\b(?!1p)\d+px){2}.*?\K\b(?!1p)(\d+)(px)"
Local $sString = "* {margin: 0; padding: 0; font-size: 12px; color: #555;}" & @CRLF & _
"" & @CRLF & _
".test {" & @CRLF & _
" display: inline-block;" & @CRLF & _
" border: 1px solid #000;" & @CRLF & _
" box-shadow: #aaa 4px 2px 6px;" & @CRLF & _
" width: 36px;" & @CRLF & _
" height: 24px;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")