import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)^(?:.*?\\b(?!1p)\\d+px){2}.*?\\K\\b(?!1p)(\\d+)(px)";
final String string = "* {margin: 0; padding: 0; font-size: 12px; color: #555;}\n\n"
+ ".test {\n"
+ " display: inline-block;\n"
+ " border: 1px solid #000;\n"
+ " box-shadow: #aaa 4px 2px 6px;\n"
+ " width: 36px;\n"
+ " height: 24px;\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}