re = /(?s)^(?:.*?\b(?!1p)\d+px){2}.*?\K\b(?!1p)(\d+)(px)/m
str = '* {margin: 0; padding: 0; font-size: 12px; color: #555;}
.test {
display: inline-block;
border: 1px solid #000;
box-shadow: #aaa 4px 2px 6px;
width: 36px;
height: 24px;
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end