const regex = /^(?=.*\bgermany\b).*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*\\bgermany\\b).*$', 'gmi')
const str = `some data germany some other data
some data Germany some other data
some data GERMANY some other data
some data France some other data
some data UK some other data`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}