$re = '/^(?=.*\bgermany\b).*$/mi';
$str = 'some data germany some other data
some data Germany some other data
some data GERMANY some other data
some data France some other data
some data UK some other data';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);