re = /^(?=.*\bgermany\b).*$/mi
str = 'some data germany some other data
some data Germany some other data
some data GERMANY some other data
some data France some other data
some data UK some other data'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end