import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?\\d+$";
final String string = "12\n"
+ "-12\n"
+ "1-2\n"
+ "12-\n"
+ "abc\n"
+ "1abc\n"
+ "abc1\n"
+ "a2c\n"
+ "-abc\n"
+ "abc-\n"
+ "a-b\n"
+ "-12abc\n"
+ "12-abc\n"
+ "12abc-\n"
+ "1.2\n"
+ ".12\n"
+ "12.\n"
+ "1,2\n"
+ "12,\n"
+ ",12\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}