$re = '/^-?\d+$/m';
$str = '12
-12
1-2
12-
abc
1abc
abc1
a2c
-abc
abc-
a-b
-12abc
12-abc
12abc-
1.2
.12
12.
1,2
12,
,12
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);