re = /^-?\d+$/m
str = '12
-12
1-2
12-
abc
1abc
abc1
a2c
-abc
abc-
a-b
-12abc
12-abc
12abc-
1.2
.12
12.
1,2
12,
,12
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end