#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=COLLAPSE\sMULTIPLIER\s=\s)(\d*.?\d*)"
Local $sString = "" & @CRLF & _
"==========================================================================" & @CRLF & _
"STAGE: C/D=1, Fc, Ø=0, LB" & @CRLF & _
"ANALYSIS TYPE: Limit Analysis " & @CRLF & _
"ELEMENT TYPE: Lower " & @CRLF & _
"TIME SCOPE: Long Term " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"ADAPT ITR COLLAPSE SOLVER STATUS " & @CRLF & _
"STEP MULTIPLIER " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"1 1 1.918E+00 Converged " & @CRLF & _
"2 1 1.944E+00 Converged " & @CRLF & _
"3 1 1.945E+00 Converged " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"No OF TRIANGLES = 1890" & @CRLF & _
"No OF EDGES = 2861" & @CRLF & _
"No OF NODES = 972" & @CRLF & _
"" & @CRLF & _
"COLLAPSE MULTIPLIER = 1.945" & @CRLF & _
"==========================================================================" & @CRLF & _
"==========================================================================" & @CRLF & _
"STAGE: C/D=2, Fc, Ø=0, LB" & @CRLF & _
"ANALYSIS TYPE: Limit Analysis " & @CRLF & _
"ELEMENT TYPE: Lower " & @CRLF & _
"TIME SCOPE: Long Term " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"ADAPT ITR COLLAPSE SOLVER STATUS " & @CRLF & _
"STEP MULTIPLIER " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"1 1 3.505E+00 Converged " & @CRLF & _
"2 1 3.613E+00 Converged " & @CRLF & _
"3 1 3.594E+00 Converged " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"No OF TRIANGLES = 1818" & @CRLF & _
"No OF EDGES = 2759" & @CRLF & _
"No OF NODES = 942" & @CRLF & _
"" & @CRLF & _
"COLLAPSE MULTIPLIER = 3.594" & @CRLF & _
"==========================================================================" & @CRLF & _
"==========================================================================" & @CRLF & _
"STAGE: C/D=3, Fc, Ø=0, LB" & @CRLF & _
"ANALYSIS TYPE: Limit Analysis " & @CRLF & _
"ELEMENT TYPE: Lower " & @CRLF & _
"TIME SCOPE: Long Term " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"ADAPT ITR COLLAPSE SOLVER STATUS " & @CRLF & _
"STEP MULTIPLIER " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"1 1 4.493E+00 Converged " & @CRLF & _
"2 1 4.632E+00 Converged " & @CRLF & _
"3 1 4.648E+00 Converged " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"No OF TRIANGLES = 1850" & @CRLF & _
"No OF EDGES = 2809" & @CRLF & _
"No OF NODES = 960" & @CRLF & _
"" & @CRLF & _
"COLLAPSE MULTIPLIER = 4.648" & @CRLF & _
"==========================================================================" & @CRLF & _
"==========================================================================" & @CRLF & _
"STAGE: C/D=4, Fc, Ø=0, LB" & @CRLF & _
"ANALYSIS TYPE: Limit Analysis " & @CRLF & _
"ELEMENT TYPE: Lower " & @CRLF & _
"TIME SCOPE: Long Term " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"ADAPT ITR COLLAPSE SOLVER STATUS " & @CRLF & _
"STEP MULTIPLIER " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"1 1 5.111E+00 Converged " & @CRLF & _
"2 1 5.368E+00 Converged " & @CRLF & _
"3 1 5.361E+00 Converged " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"No OF TRIANGLES = 1878" & @CRLF & _
"No OF EDGES = 2851" & @CRLF & _
"No OF NODES = 974" & @CRLF & _
"" & @CRLF & _
"COLLAPSE MULTIPLIER = 5.361" & @CRLF & _
"==========================================================================" & @CRLF & _
"==========================================================================" & @CRLF & _
"STAGE: C/D=5, Fc, Ø=0, LB" & @CRLF & _
"ANALYSIS TYPE: Limit Analysis " & @CRLF & _
"ELEMENT TYPE: Lower " & @CRLF & _
"TIME SCOPE: Long Term " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"ADAPT ITR COLLAPSE SOLVER STATUS " & @CRLF & _
"STEP MULTIPLIER " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"1 1 5.768E+00 Converged " & @CRLF & _
"2 1 5.903E+00 Converged " & @CRLF & _
"3 1 5.898E+00 Converged " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"No OF TRIANGLES = 1909" & @CRLF & _
"No OF EDGES = 2900" & @CRLF & _
"No OF NODES = 992" & @CRLF & _
"" & @CRLF & _
"COLLAPSE MULTIPLIER = 5.898" & @CRLF & _
"==========================================================================" & @CRLF & _
"==========================================================================" & @CRLF & _
"STAGE: C/D=6, Fc, Ø=0, LB" & @CRLF & _
"ANALYSIS TYPE: Limit Analysis " & @CRLF & _
"ELEMENT TYPE: Lower " & @CRLF & _
"TIME SCOPE: Long Term " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"ADAPT ITR COLLAPSE SOLVER STATUS " & @CRLF & _
"STEP MULTIPLIER " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"1 1 6.088E+00 Converged " & @CRLF & _
"2 1 6.312E+00 Converged " & @CRLF & _
"3 1 6.360E+00 Converged " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"No OF TRIANGLES = 1868" & @CRLF & _
"No OF EDGES = 2841" & @CRLF & _
"No OF NODES = 974" & @CRLF & _
"" & @CRLF & _
"COLLAPSE MULTIPLIER = 6.360" & @CRLF & _
"==========================================================================" & @CRLF & _
"==========================================================================" & @CRLF & _
"STAGE: C/D=7, Fc, Ø=0, LB" & @CRLF & _
"ANALYSIS TYPE: Limit Analysis " & @CRLF & _
"ELEMENT TYPE: Lower " & @CRLF & _
"TIME SCOPE: Long Term " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"ADAPT ITR COLLAPSE SOLVER STATUS " & @CRLF & _
"STEP MULTIPLIER " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"1 1 6.309E+00 Converged " & @CRLF & _
"2 1 6.671E+00 Converged " & @CRLF & _
"3 1 6.727E+00 Converged " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"No OF TRIANGLES = 1955" & @CRLF & _
"No OF EDGES = 2974" & @CRLF & _
"No OF NODES = 1020" & @CRLF & _
"" & @CRLF & _
"COLLAPSE MULTIPLIER = 6.727" & @CRLF & _
"==========================================================================" & @CRLF & _
"==========================================================================" & @CRLF & _
"STAGE: C/D=8, Fc, Ø=0, LB" & @CRLF & _
"ANALYSIS TYPE: Limit Analysis " & @CRLF & _
"ELEMENT TYPE: Lower " & @CRLF & _
"TIME SCOPE: Long Term " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"ADAPT ITR COLLAPSE SOLVER STATUS " & @CRLF & _
"STEP MULTIPLIER " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"1 1 6.534E+00 Converged " & @CRLF & _
"2 1 6.981E+00 Converged " & @CRLF & _
"3 1 7.038E+00 Converged " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"No OF TRIANGLES = 1798" & @CRLF & _
"No OF EDGES = 2738" & @CRLF & _
"No OF NODES = 941" & @CRLF & _
"" & @CRLF & _
"COLLAPSE MULTIPLIER = 7.038" & @CRLF & _
"==========================================================================" & @CRLF & _
"==========================================================================" & @CRLF & _
"STAGE: C/D=9, Fc, Ø=0, LB" & @CRLF & _
"ANALYSIS TYPE: Limit Analysis " & @CRLF & _
"ELEMENT TYPE: Lower " & @CRLF & _
"TIME SCOPE: Long Term " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"ADAPT ITR COLLAPSE SOLVER STATUS " & @CRLF & _
"STEP MULTIPLIER " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"1 1 6.691E+00 Converged " & @CRLF & _
"2 1 7.284E+00 Converged " & @CRLF & _
"3 1 7.337E+00 Converged " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"No OF TRIANGLES = 1852" & @CRLF & _
"No OF EDGES = 2820" & @CRLF & _
"No OF NODES = 969" & @CRLF & _
"" & @CRLF & _
"COLLAPSE MULTIPLIER = 7.337" & @CRLF & _
"==========================================================================" & @CRLF & _
"==========================================================================" & @CRLF & _
"STAGE: C/D=10, Fc, Ø=0, LB" & @CRLF & _
"ANALYSIS TYPE: Limit Analysis " & @CRLF & _
"ELEMENT TYPE: Lower " & @CRLF & _
"TIME SCOPE: Long Term " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"ADAPT ITR COLLAPSE SOLVER STATUS " & @CRLF & _
"STEP MULTIPLIER " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"1 1 6.900E+00 Converged " & @CRLF & _
"2 1 7.506E+00 Converged " & @CRLF & _
"3 1 7.584E+00 Converged " & @CRLF & _
"--------------------------------------------------------------------------" & @CRLF & _
"No OF TRIANGLES = 1868" & @CRLF & _
"No OF EDGES = 2843" & @CRLF & _
"No OF NODES = 976" & @CRLF & _
"" & @CRLF & _
"COLLAPSE MULTIPLIER = 7.584" & @CRLF & _
"=========================================================================="
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")