import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=COLLAPSE\\sMULTIPLIER\\s=\\s)(\\d*.?\\d*)";
final String string = "\n"
+ "==========================================================================\n"
+ "STAGE: C/D=1, Fc, Ø=0, LB\n"
+ "ANALYSIS TYPE: Limit Analysis \n"
+ "ELEMENT TYPE: Lower \n"
+ "TIME SCOPE: Long Term \n"
+ "--------------------------------------------------------------------------\n"
+ "ADAPT ITR COLLAPSE SOLVER STATUS \n"
+ "STEP MULTIPLIER \n"
+ "--------------------------------------------------------------------------\n"
+ "1 1 1.918E+00 Converged \n"
+ "2 1 1.944E+00 Converged \n"
+ "3 1 1.945E+00 Converged \n"
+ "--------------------------------------------------------------------------\n"
+ "No OF TRIANGLES = 1890\n"
+ "No OF EDGES = 2861\n"
+ "No OF NODES = 972\n\n"
+ "COLLAPSE MULTIPLIER = 1.945\n"
+ "==========================================================================\n"
+ "==========================================================================\n"
+ "STAGE: C/D=2, Fc, Ø=0, LB\n"
+ "ANALYSIS TYPE: Limit Analysis \n"
+ "ELEMENT TYPE: Lower \n"
+ "TIME SCOPE: Long Term \n"
+ "--------------------------------------------------------------------------\n"
+ "ADAPT ITR COLLAPSE SOLVER STATUS \n"
+ "STEP MULTIPLIER \n"
+ "--------------------------------------------------------------------------\n"
+ "1 1 3.505E+00 Converged \n"
+ "2 1 3.613E+00 Converged \n"
+ "3 1 3.594E+00 Converged \n"
+ "--------------------------------------------------------------------------\n"
+ "No OF TRIANGLES = 1818\n"
+ "No OF EDGES = 2759\n"
+ "No OF NODES = 942\n\n"
+ "COLLAPSE MULTIPLIER = 3.594\n"
+ "==========================================================================\n"
+ "==========================================================================\n"
+ "STAGE: C/D=3, Fc, Ø=0, LB\n"
+ "ANALYSIS TYPE: Limit Analysis \n"
+ "ELEMENT TYPE: Lower \n"
+ "TIME SCOPE: Long Term \n"
+ "--------------------------------------------------------------------------\n"
+ "ADAPT ITR COLLAPSE SOLVER STATUS \n"
+ "STEP MULTIPLIER \n"
+ "--------------------------------------------------------------------------\n"
+ "1 1 4.493E+00 Converged \n"
+ "2 1 4.632E+00 Converged \n"
+ "3 1 4.648E+00 Converged \n"
+ "--------------------------------------------------------------------------\n"
+ "No OF TRIANGLES = 1850\n"
+ "No OF EDGES = 2809\n"
+ "No OF NODES = 960\n\n"
+ "COLLAPSE MULTIPLIER = 4.648\n"
+ "==========================================================================\n"
+ "==========================================================================\n"
+ "STAGE: C/D=4, Fc, Ø=0, LB\n"
+ "ANALYSIS TYPE: Limit Analysis \n"
+ "ELEMENT TYPE: Lower \n"
+ "TIME SCOPE: Long Term \n"
+ "--------------------------------------------------------------------------\n"
+ "ADAPT ITR COLLAPSE SOLVER STATUS \n"
+ "STEP MULTIPLIER \n"
+ "--------------------------------------------------------------------------\n"
+ "1 1 5.111E+00 Converged \n"
+ "2 1 5.368E+00 Converged \n"
+ "3 1 5.361E+00 Converged \n"
+ "--------------------------------------------------------------------------\n"
+ "No OF TRIANGLES = 1878\n"
+ "No OF EDGES = 2851\n"
+ "No OF NODES = 974\n\n"
+ "COLLAPSE MULTIPLIER = 5.361\n"
+ "==========================================================================\n"
+ "==========================================================================\n"
+ "STAGE: C/D=5, Fc, Ø=0, LB\n"
+ "ANALYSIS TYPE: Limit Analysis \n"
+ "ELEMENT TYPE: Lower \n"
+ "TIME SCOPE: Long Term \n"
+ "--------------------------------------------------------------------------\n"
+ "ADAPT ITR COLLAPSE SOLVER STATUS \n"
+ "STEP MULTIPLIER \n"
+ "--------------------------------------------------------------------------\n"
+ "1 1 5.768E+00 Converged \n"
+ "2 1 5.903E+00 Converged \n"
+ "3 1 5.898E+00 Converged \n"
+ "--------------------------------------------------------------------------\n"
+ "No OF TRIANGLES = 1909\n"
+ "No OF EDGES = 2900\n"
+ "No OF NODES = 992\n\n"
+ "COLLAPSE MULTIPLIER = 5.898\n"
+ "==========================================================================\n"
+ "==========================================================================\n"
+ "STAGE: C/D=6, Fc, Ø=0, LB\n"
+ "ANALYSIS TYPE: Limit Analysis \n"
+ "ELEMENT TYPE: Lower \n"
+ "TIME SCOPE: Long Term \n"
+ "--------------------------------------------------------------------------\n"
+ "ADAPT ITR COLLAPSE SOLVER STATUS \n"
+ "STEP MULTIPLIER \n"
+ "--------------------------------------------------------------------------\n"
+ "1 1 6.088E+00 Converged \n"
+ "2 1 6.312E+00 Converged \n"
+ "3 1 6.360E+00 Converged \n"
+ "--------------------------------------------------------------------------\n"
+ "No OF TRIANGLES = 1868\n"
+ "No OF EDGES = 2841\n"
+ "No OF NODES = 974\n\n"
+ "COLLAPSE MULTIPLIER = 6.360\n"
+ "==========================================================================\n"
+ "==========================================================================\n"
+ "STAGE: C/D=7, Fc, Ø=0, LB\n"
+ "ANALYSIS TYPE: Limit Analysis \n"
+ "ELEMENT TYPE: Lower \n"
+ "TIME SCOPE: Long Term \n"
+ "--------------------------------------------------------------------------\n"
+ "ADAPT ITR COLLAPSE SOLVER STATUS \n"
+ "STEP MULTIPLIER \n"
+ "--------------------------------------------------------------------------\n"
+ "1 1 6.309E+00 Converged \n"
+ "2 1 6.671E+00 Converged \n"
+ "3 1 6.727E+00 Converged \n"
+ "--------------------------------------------------------------------------\n"
+ "No OF TRIANGLES = 1955\n"
+ "No OF EDGES = 2974\n"
+ "No OF NODES = 1020\n\n"
+ "COLLAPSE MULTIPLIER = 6.727\n"
+ "==========================================================================\n"
+ "==========================================================================\n"
+ "STAGE: C/D=8, Fc, Ø=0, LB\n"
+ "ANALYSIS TYPE: Limit Analysis \n"
+ "ELEMENT TYPE: Lower \n"
+ "TIME SCOPE: Long Term \n"
+ "--------------------------------------------------------------------------\n"
+ "ADAPT ITR COLLAPSE SOLVER STATUS \n"
+ "STEP MULTIPLIER \n"
+ "--------------------------------------------------------------------------\n"
+ "1 1 6.534E+00 Converged \n"
+ "2 1 6.981E+00 Converged \n"
+ "3 1 7.038E+00 Converged \n"
+ "--------------------------------------------------------------------------\n"
+ "No OF TRIANGLES = 1798\n"
+ "No OF EDGES = 2738\n"
+ "No OF NODES = 941\n\n"
+ "COLLAPSE MULTIPLIER = 7.038\n"
+ "==========================================================================\n"
+ "==========================================================================\n"
+ "STAGE: C/D=9, Fc, Ø=0, LB\n"
+ "ANALYSIS TYPE: Limit Analysis \n"
+ "ELEMENT TYPE: Lower \n"
+ "TIME SCOPE: Long Term \n"
+ "--------------------------------------------------------------------------\n"
+ "ADAPT ITR COLLAPSE SOLVER STATUS \n"
+ "STEP MULTIPLIER \n"
+ "--------------------------------------------------------------------------\n"
+ "1 1 6.691E+00 Converged \n"
+ "2 1 7.284E+00 Converged \n"
+ "3 1 7.337E+00 Converged \n"
+ "--------------------------------------------------------------------------\n"
+ "No OF TRIANGLES = 1852\n"
+ "No OF EDGES = 2820\n"
+ "No OF NODES = 969\n\n"
+ "COLLAPSE MULTIPLIER = 7.337\n"
+ "==========================================================================\n"
+ "==========================================================================\n"
+ "STAGE: C/D=10, Fc, Ø=0, LB\n"
+ "ANALYSIS TYPE: Limit Analysis \n"
+ "ELEMENT TYPE: Lower \n"
+ "TIME SCOPE: Long Term \n"
+ "--------------------------------------------------------------------------\n"
+ "ADAPT ITR COLLAPSE SOLVER STATUS \n"
+ "STEP MULTIPLIER \n"
+ "--------------------------------------------------------------------------\n"
+ "1 1 6.900E+00 Converged \n"
+ "2 1 7.506E+00 Converged \n"
+ "3 1 7.584E+00 Converged \n"
+ "--------------------------------------------------------------------------\n"
+ "No OF TRIANGLES = 1868\n"
+ "No OF EDGES = 2843\n"
+ "No OF NODES = 976\n\n"
+ "COLLAPSE MULTIPLIER = 7.584\n"
+ "==========================================================================";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}