re = /(?<=COLLAPSE\sMULTIPLIER\s=\s)(\d*.?\d*)/m
str = '
==========================================================================
STAGE: C/D=1, Fc, Ø=0, LB
ANALYSIS TYPE: Limit Analysis
ELEMENT TYPE: Lower
TIME SCOPE: Long Term
--------------------------------------------------------------------------
ADAPT ITR COLLAPSE SOLVER STATUS
STEP MULTIPLIER
--------------------------------------------------------------------------
1 1 1.918E+00 Converged
2 1 1.944E+00 Converged
3 1 1.945E+00 Converged
--------------------------------------------------------------------------
No OF TRIANGLES = 1890
No OF EDGES = 2861
No OF NODES = 972
COLLAPSE MULTIPLIER = 1.945
==========================================================================
==========================================================================
STAGE: C/D=2, Fc, Ø=0, LB
ANALYSIS TYPE: Limit Analysis
ELEMENT TYPE: Lower
TIME SCOPE: Long Term
--------------------------------------------------------------------------
ADAPT ITR COLLAPSE SOLVER STATUS
STEP MULTIPLIER
--------------------------------------------------------------------------
1 1 3.505E+00 Converged
2 1 3.613E+00 Converged
3 1 3.594E+00 Converged
--------------------------------------------------------------------------
No OF TRIANGLES = 1818
No OF EDGES = 2759
No OF NODES = 942
COLLAPSE MULTIPLIER = 3.594
==========================================================================
==========================================================================
STAGE: C/D=3, Fc, Ø=0, LB
ANALYSIS TYPE: Limit Analysis
ELEMENT TYPE: Lower
TIME SCOPE: Long Term
--------------------------------------------------------------------------
ADAPT ITR COLLAPSE SOLVER STATUS
STEP MULTIPLIER
--------------------------------------------------------------------------
1 1 4.493E+00 Converged
2 1 4.632E+00 Converged
3 1 4.648E+00 Converged
--------------------------------------------------------------------------
No OF TRIANGLES = 1850
No OF EDGES = 2809
No OF NODES = 960
COLLAPSE MULTIPLIER = 4.648
==========================================================================
==========================================================================
STAGE: C/D=4, Fc, Ø=0, LB
ANALYSIS TYPE: Limit Analysis
ELEMENT TYPE: Lower
TIME SCOPE: Long Term
--------------------------------------------------------------------------
ADAPT ITR COLLAPSE SOLVER STATUS
STEP MULTIPLIER
--------------------------------------------------------------------------
1 1 5.111E+00 Converged
2 1 5.368E+00 Converged
3 1 5.361E+00 Converged
--------------------------------------------------------------------------
No OF TRIANGLES = 1878
No OF EDGES = 2851
No OF NODES = 974
COLLAPSE MULTIPLIER = 5.361
==========================================================================
==========================================================================
STAGE: C/D=5, Fc, Ø=0, LB
ANALYSIS TYPE: Limit Analysis
ELEMENT TYPE: Lower
TIME SCOPE: Long Term
--------------------------------------------------------------------------
ADAPT ITR COLLAPSE SOLVER STATUS
STEP MULTIPLIER
--------------------------------------------------------------------------
1 1 5.768E+00 Converged
2 1 5.903E+00 Converged
3 1 5.898E+00 Converged
--------------------------------------------------------------------------
No OF TRIANGLES = 1909
No OF EDGES = 2900
No OF NODES = 992
COLLAPSE MULTIPLIER = 5.898
==========================================================================
==========================================================================
STAGE: C/D=6, Fc, Ø=0, LB
ANALYSIS TYPE: Limit Analysis
ELEMENT TYPE: Lower
TIME SCOPE: Long Term
--------------------------------------------------------------------------
ADAPT ITR COLLAPSE SOLVER STATUS
STEP MULTIPLIER
--------------------------------------------------------------------------
1 1 6.088E+00 Converged
2 1 6.312E+00 Converged
3 1 6.360E+00 Converged
--------------------------------------------------------------------------
No OF TRIANGLES = 1868
No OF EDGES = 2841
No OF NODES = 974
COLLAPSE MULTIPLIER = 6.360
==========================================================================
==========================================================================
STAGE: C/D=7, Fc, Ø=0, LB
ANALYSIS TYPE: Limit Analysis
ELEMENT TYPE: Lower
TIME SCOPE: Long Term
--------------------------------------------------------------------------
ADAPT ITR COLLAPSE SOLVER STATUS
STEP MULTIPLIER
--------------------------------------------------------------------------
1 1 6.309E+00 Converged
2 1 6.671E+00 Converged
3 1 6.727E+00 Converged
--------------------------------------------------------------------------
No OF TRIANGLES = 1955
No OF EDGES = 2974
No OF NODES = 1020
COLLAPSE MULTIPLIER = 6.727
==========================================================================
==========================================================================
STAGE: C/D=8, Fc, Ø=0, LB
ANALYSIS TYPE: Limit Analysis
ELEMENT TYPE: Lower
TIME SCOPE: Long Term
--------------------------------------------------------------------------
ADAPT ITR COLLAPSE SOLVER STATUS
STEP MULTIPLIER
--------------------------------------------------------------------------
1 1 6.534E+00 Converged
2 1 6.981E+00 Converged
3 1 7.038E+00 Converged
--------------------------------------------------------------------------
No OF TRIANGLES = 1798
No OF EDGES = 2738
No OF NODES = 941
COLLAPSE MULTIPLIER = 7.038
==========================================================================
==========================================================================
STAGE: C/D=9, Fc, Ø=0, LB
ANALYSIS TYPE: Limit Analysis
ELEMENT TYPE: Lower
TIME SCOPE: Long Term
--------------------------------------------------------------------------
ADAPT ITR COLLAPSE SOLVER STATUS
STEP MULTIPLIER
--------------------------------------------------------------------------
1 1 6.691E+00 Converged
2 1 7.284E+00 Converged
3 1 7.337E+00 Converged
--------------------------------------------------------------------------
No OF TRIANGLES = 1852
No OF EDGES = 2820
No OF NODES = 969
COLLAPSE MULTIPLIER = 7.337
==========================================================================
==========================================================================
STAGE: C/D=10, Fc, Ø=0, LB
ANALYSIS TYPE: Limit Analysis
ELEMENT TYPE: Lower
TIME SCOPE: Long Term
--------------------------------------------------------------------------
ADAPT ITR COLLAPSE SOLVER STATUS
STEP MULTIPLIER
--------------------------------------------------------------------------
1 1 6.900E+00 Converged
2 1 7.506E+00 Converged
3 1 7.584E+00 Converged
--------------------------------------------------------------------------
No OF TRIANGLES = 1868
No OF EDGES = 2843
No OF NODES = 976
COLLAPSE MULTIPLIER = 7.584
=========================================================================='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end