using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"circle|triangle|hexagon";
string input = @"The three incoming shapes are circle, triangle and a rectangle.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}