re = /circle|triangle|hexagon/m
str = 'The three incoming shapes are circle, triangle and a rectangle.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end