package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)circle|triangle|hexagon`)
var str = `The three incoming shapes are circle, triangle and a rectangle.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}