import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Total\\r?\\n\\r?\\n?)(.+)(?=\\s+\\d+\\s+\\d+\\s+[A-z]{3})";
final String string = "Item Description Quantity Price Per Total\n\n"
+ "Various paper supplies 1 269033 USD 269033 USD";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}