import re
regex = re.compile(r"(?<=Total\r?\n\r?\n?)(.+)(?=\s+\d+\s+\d+\s+[A-z]{3})", flags=re.MULTILINE)
test_str = ("Item Description Quantity Price Per Total\n\n"
"Various paper supplies 1 269033 USD 269033 USD")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")