const regex = /^Movie\s+\S+\s+(S\d{2}\s+E\d{2}(?=\s+\d{4}))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Movie\\s+\\S+\\s+(S\\d{2}\\s+E\\d{2}(?=\\s+\\d{4}))', 'gm')
const str = `Movie TOTO S09 E22 2022 Copyright`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}