$re = '/^Movie\s+\S+\s+(S\d{2}\s+E\d{2}(?=\s+\d{4}))/m';
$str = 'Movie TOTO S09 E22 2022 Copyright';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);