re = /^Movie\s+\S+\s+(S\d{2}\s+E\d{2}(?=\s+\d{4}))/m
str = 'Movie TOTO S09 E22 2022 Copyright'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end