$re = '/(?P<action>MY-DATA)\s+:desc:(?P<desc>.+):\s+:priority:(?P<priority>.+):/m';
$str = 'MY-DATA :desc:please provide my information about https://mydata.com/thisismydata: :priority:3:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);