// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<action>MY-DATA)\s+:desc:(?P<desc>.+):\s+:priority:(?P<priority>.+):").unwrap();
let string = "MY-DATA :desc:please provide my information about https://mydata.com/thisismydata: :priority:3:";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}