re = /(?P<action>MY-DATA)\s+:desc:(?P<desc>.+):\s+:priority:(?P<priority>.+):/m
str = 'MY-DATA :desc:please provide my information about https://mydata.com/thisismydata: :priority:3:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end