using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\^1234(.*?), \^5678";
string input = @"54:16812344266, ^1234:iwantthistext, ^5678:idontwantthis, ^0000: idontwantthiseithere";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}