package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\^1234(.*?), \^5678`)
var str = `54:16812344266, ^1234:iwantthistext, ^5678:idontwantthis, ^0000: idontwantthiseithere`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}