re = /\^1234(.*?), \^5678/m
str = '54:16812344266, ^1234:iwantthistext, ^5678:idontwantthis, ^0000: idontwantthiseithere'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end