using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"before\"":\""(?<summary_before>[^\""]+)\"".\""after\"":\""(?<summary_after>[^\""]+)";
string input = @"""changes"":{""description"":{""before"":""<some text or empty>"",""after"":""<some text or empty>""}}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}