package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)before\":\"(?<summary_before>[^\"]+)\".\"after\":\"(?<summary_after>[^\"]+)`)
var str = `"changes":{"description":{"before":"<some text or empty>","after":"<some text or empty>"}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}