$re = '/before\":\"(?<summary_before>[^\"]+)\".\"after\":\"(?<summary_after>[^\"]+)/m';
$str = '"changes":{"description":{"before":"<some text or empty>","after":"<some text or empty>"}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);