#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)F(?:SC)?-?(\d{3})"
Local $sString = "20220213-0000-FSC-814-SC_VIRG_REFBAL_PRES_NPMINMAX-v1.xml" & @CRLF & _
"20220213-0000-F814-SC_VIRG_REFBAL_PRES_NPMINMAX-v1.xml"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")