use strict;
my $str = '20220213-0000-FSC-814-SC_VIRG_REFBAL_PRES_NPMINMAX-v1.xml
20220213-0000-F814-SC_VIRG_REFBAL_PRES_NPMINMAX-v1.xml';
my $regex = qr/F(?:SC)?-?(\d{3})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}