import re
regex = re.compile(r"F(?:SC)?-?(\d{3})", flags=re.MULTILINE)
test_str = ("20220213-0000-FSC-814-SC_VIRG_REFBAL_PRES_NPMINMAX-v1.xml\n"
"20220213-0000-F814-SC_VIRG_REFBAL_PRES_NPMINMAX-v1.xml")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")