import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "field: \"(.*?)\"";
final String string = "{field: \"platformID\",\n"
+ " displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
+ " quickSearch: true,\n"
+ " search: {operator: ['eq', 'ne', 'cn', 'gt', 'lt']},\n"
+ " sortFunc: 'number'\n"
+ "},\n"
+ "{field: \"platformName\",\n"
+ " displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
+ " quickSearch: true,\n"
+ " cellTemplate: '<a href=\"#/clemove/clemoveDetaiPlatform/{{row.platformID}}\" translate=\"{{row.platformID}}\"></a>',\n"
+ " search: {operator: ['eq', 'cn']},\n"
+ "},\n"
+ "{field: \"platformOwnerTEF\",\n"
+ " displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
+ " quickSearch: true,\n"
+ " search: {operator: ['eq', 'cn']},\n"
+ " sortFunc: 'number'\n"
+ "},\n"
+ "{field: \"platformOwnerZTE\",\n"
+ " displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
+ " quickSearch: true,\n"
+ " search: {operator: ['eq', 'cn']},\n"
+ " sortFunc: 'number'\n"
+ "},\n"
+ "{field: \"platformVendor\",\n"
+ " displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
+ " quickSearch: true,\n"
+ " search: {operator: ['eq', 'cn']},\n"
+ " sortFunc: 'number'\n"
+ "},\n"
+ "{field: \"platformE2E\",\n"
+ " displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
+ " quickSearch: true,\n"
+ " search: {operator: ['eq', 'cn']},\n"
+ "},\n"
+ "{field: \"platformInternalDependency\",\n"
+ " displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
+ " quickSearch: true,\n"
+ " search: {operator: ['eq', 'cn']},\n"
+ "},\n"
+ "{field: \"platformServiceDependency\",\n"
+ " displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
+ " quickSearch: true,\n"
+ " search: {operator: ['eq', 'cn']},\n"
+ "},\n"
+ "{field: \"platformPreferedMoveDate\",\n"
+ " displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
+ " quickSearch: true,\n"
+ " search: {operator: ['eq', 'cn']},\n"
+ "},\n"
+ "{field: \"platformUnpreferedMoveDate\",\n"
+ " displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
+ " quickSearch: true,\n"
+ " search: {operator: ['eq', 'cn']},\n"
+ "},\n"
+ "{field: \"platformAdditionalTool\",\n"
+ " displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
+ " quickSearch: true,\n"
+ " search: {operator: ['eq', 'cn']},\n"
+ "},\n"
+ "{field: \"platformVM\",\n"
+ " displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
+ " quickSearch: true,\n"
+ " search: {operator: ['eq', 'cn']},\n"
+ "},\n"
+ "{field: \"platformCommunicationMatrix\",\n"
+ " displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
+ " quickSearch: true,\n"
+ " search: {operator: ['eq', 'cn']},\n"
+ "},\n"
+ "{field: \"stateName\",\n"
+ " displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
+ " quickSearch: true,\n"
+ " search: {operator: ['eq', 'cn']},\n"
+ " cellFilter: 'translate',\n"
+ "},\n"
+ "{field: \"modeName\",\n"
+ " displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
+ " quickSearch: true,\n"
+ " search: {operator: ['eq', 'cn']},\n"
+ "},\n"
+ "{field: \"relocationgroupName\",\n"
+ " displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
+ " quickSearch: true,\n"
+ " search: {operator: ['eq', 'cn']},\n"
+ "},";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}