using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{14,}0000$)[pP][a-zA-Z0-9]*(?:(?(1)\1|([- +]|%20)?)[a-zA-Z0-9]+)*$";
string input = @"PLX000000000PQ50000
pLX000000000PQ50000
plx000000000pq50000
PLX-0000-0000-0PQ5-0000
PLX-0000-0000-0PQ50000
PLX+0000+0000+0PQ5+0000
PLX%200000%200000%200PQ5%200000
PLX 0000 0000 0PQ5 0000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}