re = /^(?=.{14,}0000$)[pP][a-zA-Z0-9]*(?:(?(1)\1|([- +]|%20)?)[a-zA-Z0-9]+)*$/m
str = 'PLX000000000PQ50000
pLX000000000PQ50000
plx000000000pq50000
PLX-0000-0000-0PQ5-0000
PLX-0000-0000-0PQ50000
PLX+0000+0000+0PQ5+0000
PLX%200000%200000%200PQ5%200000
PLX 0000 0000 0PQ5 0000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end