use strict;
my $str = 'PLX000000000PQ50000
pLX000000000PQ50000
plx000000000pq50000
PLX-0000-0000-0PQ5-0000
PLX-0000-0000-0PQ50000
PLX+0000+0000+0PQ5+0000
PLX%200000%200000%200PQ5%200000
PLX 0000 0000 0PQ5 0000';
my $regex = qr/^(?=.{14,}0000$)[pP][a-zA-Z0-9]*(?:(?(1)\1|([- +]|%20)?)[a-zA-Z0-9]+)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}