$re = '/^.*?(?:cot|lan)\s*/m';
$str = 'The cot that I bought yesterday is the cheapest one';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);