re = /^.*?(?:cot|lan)\s*/m
str = 'The cot that I bought yesterday is the cheapest one'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end