package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<iframe.*class=\"embedly-embed\".*src=\"(.+?)\"`)
var str = `
<iframe class="embedly-embed" src="https://api.com" scrolling="no" frameborder="0" allowfullscreen=""></iframe>
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}