re = /<iframe.*class=\"embedly-embed\".*src=\"(.+?)\"/
str = '
<iframe class="embedly-embed" src="https://api.com" scrolling="no" frameborder="0" allowfullscreen=""></iframe>
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end