$re = '/<iframe.*class=\"embedly-embed\".*src=\"(.+?)\"/';
$str = '
<iframe class="embedly-embed" src="https://api.com" scrolling="no" frameborder="0" allowfullscreen=""></iframe>
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);