const regex = /(?<=\d)_\d(*SKIP)(*FAIL)|_/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d)_\\d(*SKIP)(*FAIL)|_', 'gm')
const str = `_this_is_a_2_2_replacement_`;
const subst = `.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);