use strict;
my $str = '_this_is_a_2_2_replacement_';
my $regex = qr/(?<=\d)_\d(*SKIP)(*FAIL)|_/mp;
my $subst = '.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";