using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"state\s:\s([A-Z_-]+)\|[^\|]+\|$";
string input = @"08:45:16.674 [2018-01-03T08:45:16.674+0000] 3950682 INFO [p-quote-13-13-L-1] --- LoggerUtil: STATE ENGINE|AA32699|Quote21849812-0|Quote message arrived in state : RECORD_KEEPING_END|110|";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}