package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`state\s:\s([A-Z_-]+)\|[^\|]+\|$`)
var str = `08:45:16.674 [2018-01-03T08:45:16.674+0000] 3950682 INFO [p-quote-13-13-L-1] --- LoggerUtil: STATE ENGINE|AA32699|Quote21849812-0|Quote message arrived in state : RECORD_KEEPING_END|110|`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}