$re = '/state\s:\s([A-Z_-]+)\|[^\|]+\|$/';
$str = '08:45:16.674 [2018-01-03T08:45:16.674+0000] 3950682 INFO [p-quote-13-13-L-1] --- LoggerUtil: STATE ENGINE|AA32699|Quote21849812-0|Quote message arrived in state : RECORD_KEEPING_END|110|';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);