package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d`)
var str = `Le monde - Vendredi 22 Avril.pdf
Le Monde du 22 Avril 2022 Pdf`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}