re = /\d/m
str = 'Le monde - Vendredi 22 Avril.pdf
Le Monde du 22 Avril 2022 Pdf'
# Print the match result
str.match(re) do |match|
puts match.to_s
end